باگ امنیتی خطرناک در افزونه Duplicator وردپرس

باگ امنیتی خطرناک در افزونه Duplicator وردپرس

باگ امنیتی خطرناک در افزونه Duplicator وردپرس
5 (100%) 7 votes

با توجه به محبوبیت وردپرس و درصد بالای وب سایت هایی که از این نوع اسکریپت استفاده میکنند همواره وردپرس مورد توجه هکر ها بوده و تهدید های زیادی را به همراه دارد البته با انجام موارد هایی که در پارس وب سرور به آن پرداخته شده است می توان درصد قابل توجه ای از تهدیدات احتمالی را کم کرد.

 

باگ امنیتی در وردپرس باگ امنیتی در وردپرس

 

متاسفانه جدیدا گزارش هایی مبنی بر هک شدن بعضی از وب سایت های وردپرسی داشتیم و با بررسی هایی که صورت گرفته در این وب سایت ها افزونه Duplicator نصب و فعال بوده است که این افزونه باگ امنیتی خطرناکی را برای وب سایت ایجاد میکند.

 

افزونه Duplicator چیست و چگونه باعث هک شدن وب سایت ها می شود؟

 

افزونه Duplicator امکان ساخت بسته آسان نصب وردپرس را برای کاربران فراهم میکند. توسط این افزونه می توان از یک وب سایت به صورت کامل کپی تهیه کرد و بر روی هاست دیگر آن را نصب و راه اندازی کرد تا یک وب سایت دیگر با همان ظاهر و محتوای وب سایت قبلی داشته باشید.

متاسفانه این افزونه روی بسیاری از وب سایت های وردپرسی نصب می باشد و با توجه به اینکه راه اندازی سایت توسط این افزونه بسیار ساده است محبوبت بسیار بالایی داشته و هم اکنون بیش از یک میلیون نصب فعال دارد.

این افزونه فایل های  installer.php، installer-backup.php، installer-data.sql و پوشه wp-snapshot را در کنار فایل های وردپرس شما قرار میدهد و با توجه به باگی که این افزونه دارد هکر می تواند دوباره اقدام به نصب ودپرس کند و با آپلود شل یا فایل های مخرب به فایل های کانفیگ وردپرس دسترسی پیدا کرده و آن را دستکاری کرده و سایت را از دسترس خارج کند.

اما مسئله فقط به اینجا ختم نمی شود و معمولا هکر ها با قرار دادن کد هایی داخل فایل های وردپرس بازدید کننده وب سایت شما را به وب سایت های خود هدایت میکنند. که این امر خسارت زیادی به وب سایت ها وارد میکند.

 

چطور این باگ امنیتی را برطرف کنیم؟

 

قدم اول:  وارد پیشخوان وردپرس خودتان بشوید و هسته وردپرس و افزونه هایی موجود را به آخرین نسخه به روز رسانی کنید توجه داشته باشید که اگر نیاز به به روز رسانی داشته باشند در مسیر پیشخوان و بعد به روز رسانی اخطار داده می شود.

قدم دوم: افزونه Duplicator را از قسمت افزونه ها حذف کنید و در مسیر فایل های افزونه در وردپرس مطمئن شوید که فایل های آن حذف شده است و همچنین فایل های installer.php، installer-backup.php، installer-data.sql و پوشه wp-snapshot را در صورت وجود جذف کنید.

قدم سوم: انجام حداقل مراحل ۶ و ۷ از آموزش امن کردن وردپرس با این کار درصد قابل توجه ای از ریسک امنیتی وب سایت شما کاسته خواهد شد.

 

وب سایت من با این روش هک شده است چطور برگردانم؟

 

اگر وب سایت شما توسط این باگ هک شده است بهتر است برای بخش پشتیبانی سرویس دهنده هاست خود تیکت ارسال کنید و درخواست بازگردانی بک اپ کنید و بعد از بازگردانی ۳ قدم بالا را انجام بدهید.

اما اگر با بازگردانی بک آپ مشکل وب سایت شما برطرف نشده است باید فایل wp-config.php را ویرایش کرده و اطلاعات دیتابیس را مجدد در آن وارد کنید و اگر کدهایی غیر از کد های پیشفرض وردپرس را مشاهده کردید آن را حذف کرده و فایل های installer.php، installer-backup.php، installer-data.sql و پوشه wp-snapshot  در صورت وجود در هاست نیز حذف شود.

اگر هاست را از پارس وب سرور تهیه کردید فقط کافی است این مورد را برای بخش پشتیبانی تیکت کنید تا برای شما مشکل را برطرف کنند.

 

امیدوارم مورد توجه شما قرار گرفته باشد.



شهریور ۲۸, ۱۳۹۷

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

نظرات کاربران

نماد اعتماد الکترونیکی ساماندهی درگاه به پرداخت درگاه پارسیان